¿Cómo poner @ en un comentario dentro de un JCL?

Todo lo referido a automatizadores de consola u otros (CONTROL-O, System Automation, etc)
Responder
jjcvmadrid

¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por jjcvmadrid » 28 Sep 2011, 17:04

Buenas tardes
me ha tocado hacer unos paneles informativos de los distintos clientes para soporte al operador
para ello he creado unos paneles informativos a través del Netview donde el operador con un comando de busqueda corto, recibe toda la información del cliente. ejemplo el operador da `p madagascar' ; pues sale toda la información referida a dicho cliente.
Mi problema es el siguiente, no me coje la @, asique de momento me estoy apañando con # , por ejemplo madagascar#yahoo.es
¿Podríais ayudarme cómo puedo poner la @ en el JCL? y que luego se refleje en el panel.

saludos

Vicente

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por Vicente » 29 Sep 2011, 08:50

Hola:
Ninguno de los cuatro comentarios del siguiente JCL da error

//PRUEBA1 JOB CLASS=0,MSGCLASS=A,MSGLEVEL=(1,1)
/* C@R@COL@
//* HOLA C@R@COL@
//PASO1 EXEC PGM=IEFBR14 @@@@
//SYSPRINT DD SYSOUT=* B@B@ @@

Si puedes ser más explicito y escribir el trozo de jcl que te da el error, así como el mensaje de error, quizás pueda ayudarte más

Un saludo

jjcvmadrid

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por jjcvmadrid » 29 Sep 2011, 15:38

Hola
yo en jcl puedo poner @ en una ficha comentario pero el panel de netview no ve la @, sin embargo otros carácteres si salen

En el jcl
000017 $| telefonica@net.com
000018 $| telefonica#net.com
000019 $|
000020 $|
000021 $|

En el panel del netview

telefonica net.com
telefonica#net.com

jjcvmadrid

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por jjcvmadrid » 29 Sep 2011, 15:41

Hola
yo en jcl puedo poner @ en una ficha comentario pero el panel de netview no ve la @, sin embargo otros carácteres si salen

En el jcl
000017 $| telefonica@net.com
000018 $| telefonica#net.com
000019 $|
000020 $|
000021 $|

En el panel del netview

telefonica net.com
telefonica#net.com

jjcvmadrid

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por jjcvmadrid » 29 Sep 2011, 15:42

en la linea que sale @.com
estoy poniendo telefonica luego @ luego net luego.com
telefonica@net.com

Vicente

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por Vicente » 30 Sep 2011, 09:34

Lo primero que hay que comprobar, con el mandato HEX ON del editor, es que @ es el código hexadecimal 7C, no vaya a ser que tengas el lenguage del teclado en el telnet mal.
Lo segundo, sería estudiar si @ es un caracter especial para Netview o su utilidad de paneles.

Fernan

Re: ¿Cómo poner @ en un comentario dentro de un JCL?

Mensaje por Fernan » 15 Ene 2019, 14:44

hola...

prueba a poner doble @, es decir, telefonica@@.... realizado macros en las cuales tenia que poner en recursos que empezaban por @, esta no los ponia, alponerle doble, ya funciono.

Responder